package.yaml 2.62 KB
Newer Older
1
2
3
4
5
6
7
8
9
name:    bookme
version: "0.0.0"

dependencies:

# Due to a bug in GHC 8.0.1, we block its usage
# See: https://ghc.haskell.org/trac/ghc/ticket/12130
- base >=4.8.2.0 && <4.9 || >=4.9.1.0 && <5

10
11
12
13
14
15
16
17
- aeson                  >=0.6   && <1.3
- bytestring             >=0.9   && <0.11
- case-insensitive
- classy-prelude         >=1.4   && <1.5
- classy-prelude-conduit >=1.4   && <1.5
- classy-prelude-yesod   >=1.4   && <1.5
- conduit                >=1.0   && <2.0
- containers
18
- data-default
19
- directory              >=1.1   && <1.4
20
- exceptions
21
- fast-logger            >=2.2   && <2.5
22
- file-embed
23
24
25
26
27
28
- foreign-store
- gogol                  >=0.3.0 && <0.4
- gogol-apps-calendar    >=0.3.0 && <0.4
- hjsmin                 >=0.1   && <0.3
- http-client-tls        >=0.3   && <0.4
- http-conduit           >=2.3   && <2.4
29
- http-types
30
31
32
- lens
- monad-control          >=0.3   && <1.1
- monad-logger           >=0.3   && <0.4
33
- safe
34
35
36
37
- shakespeare            >=2.0   && <2.1
- template-haskell
- text                   >=0.11  && <2.0
- time
38
39
40
- unordered-containers
- vector
- wai
41
42
43
44
45
46
47
48
- wai-extra              >=3.0   && <3.1
- wai-logger             >=2.2   && <2.4
- warp                   >=3.0   && <3.3
- yaml                   >=0.8   && <0.9
- yesod                  >=1.6   && <1.7
- yesod-core             >=1.6   && <1.7
- yesod-form             >=1.6   && <1.7
- yesod-static           >=1.6   && <1.7
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
73
74
75
76
77
78
79
80
81

# The library contains all of our application code. The executable
# defined below is just a thin wrapper.
library:
  source-dirs: src
  when:
  - condition: (flag(dev)) || (flag(library-only))
    then:
      ghc-options:
      - -Wall
      - -fwarn-tabs
      - -O0
      cpp-options: -DDEVELOPMENT
    else:
      ghc-options:
      - -Wall
      - -fwarn-tabs
      - -O2

# Runnable executable for our application
executables:
  bookme:
    main: main.hs
    source-dirs: app
    ghc-options:
    - -threaded
    - -rtsopts
    - -with-rtsopts=-N
    dependencies:
    - bookme
    when:
    - condition: flag(library-only)
      buildable: false
82
83
84
85
86
87
88
89
  bookme-authorize:
    main: auth.hs
    source-dirs: app
    dependencies:
      - bookme
    when:
      - condition: flag(library-only)
        buildable: false
90
91
92
93
94
95
96
97
98
99
100
101
102
103
104
105
106
107
108
109
110
111

# Test suite
tests:
  bookme-test:
    main: Spec.hs
    source-dirs: test
    ghc-options: -Wall
    dependencies:
    - bookme
    - hspec >=2.0.0
    - yesod-test

# Define flags used by "yesod devel" to make compilation faster
flags:
  library-only:
    description: Build for use with "yesod devel"
    manual: false
    default: false
  dev:
    description: Turn on development settings, like auto-reload templates.
    manual: false
    default: false